Windstream Internet down

Incident Report for Network Nebraska

Monitoring

Circuit came up at Jul 13 01:10, Windstream has not completed all repairs to their backbone and it is possible this could go back down again.
Posted Jul 13, 2025 - 01:59 CDT

Update

Windstream is working on two separate points of fiber damage in Iowa now. No time of restoral has been given.
Posted Jul 12, 2025 - 14:14 CDT

Update

Windstream is continuing to work on repairs, no time to restoral has been given.
Posted Jul 12, 2025 - 12:53 CDT

Update

Windstream has worked throughout the night and morning on this outage. They have repaired some damage in Omaha but they've identified further damage in Iowa and are waiting for additional people to assist in repairs. No time to restoral is available at this time.
Posted Jul 12, 2025 - 09:58 CDT

Update

Windstream has placed a replacement cable and is continuing to enact repairs. No time to restoral has been given.
Posted Jul 11, 2025 - 15:43 CDT

Update

Windstream fiber splicers have an ETA of 2:30pm CT, no time to restoral has been given.
Posted Jul 11, 2025 - 13:10 CDT

Identified

Windstream has confirmed that this is due to a fiber cut that was related to storm damage. Their construction teams were on site before 5am this morning, however they do not have an estimated time to restoral.
Posted Jul 11, 2025 - 10:35 CDT

Update

This issue was escalated with the carrier at 9:18am CT, they are continuing to investigate. No time to restoral has been given.
Posted Jul 11, 2025 - 09:55 CDT

Investigating

Windstream Internet is down as of Jul 10 22:50 CT. The vendor has been engaged and they are investigating. All traffic has failed over to redundant links.
Questions 402-472-7656 Toll Free 888-638-6327 (1-888-NET-NEBR) or noc@nebraska.edu
Posted Jul 11, 2025 - 08:15 CDT
This incident affects: Internet / Peering (Windstream).