Windstream internet down

Incident Report for Network Nebraska

Resolved

The connection has remained stable.
Posted Jun 03, 2026 - 13:04 CDT

Monitoring

The carrier replaced a faulty piece of equipment at their location and that restored service. Traffic has restored and we will continue to monitor the circuit.
Posted May 22, 2026 - 13:38 CDT

Update

The carrier is continuing to investigate. No time to restoration is available.
Posted May 22, 2026 - 13:04 CDT

Investigating

Internet via Windstream went down at 9:32a CT, the carrier has been notified and is investigating. Traffic failed over to redundant connections successfully.
Posted May 22, 2026 - 09:49 CDT
This incident affected: Internet / Peering (Windstream).