Windstream internet is down

Incident Report for Network Nebraska

Resolved

The connection has been up and stable since 10/31/25 at 10:40 pm CT.
Posted Nov 03, 2025 - 08:29 CST

Identified

Windstream has identified a fiber cut between Omaha and Des Moines. Techs have been dispatched to isolate the cut, no time to restoral has been given.
Posted Oct 31, 2025 - 18:12 CDT

Investigating

Internet via Windstream is down. Traffic has failed over to redundant connections and the carrier has been engaged.
Questions 402-472-7656 Toll Free 888-638-6327 (1-888-NET-NEBR) or noc@nebraska.edu
Posted Oct 31, 2025 - 17:14 CDT
This incident affected: Internet / Peering (Windstream).