Windstream completed work as of 7:09pm CT, the connection has remained stable.
Posted Aug 13, 2025 - 21:06 CDT
Monitoring
This connection came up 2:59pm CT and all circuits have restored. Windstream is still performing repairs, there is a chance this could go back down before they are hands-off.
Posted Aug 13, 2025 - 15:22 CDT
Update
Windstream had begun to splice fiber by 12:54pm CT today, they have yet to provide a restoral time.
Posted Aug 13, 2025 - 13:48 CDT
Update
Additional Windstream work crews were on site as of 10:30am CT to assist with repairs, no time to restoral has been given.
Posted Aug 13, 2025 - 11:27 CDT
Identified
Windstream/Uniti NOC reports that there is a fiber damage causing the current outage. Fiber technicians are currently performing repairs. No ETR at this time.
Posted Aug 12, 2025 - 18:14 CDT
Investigating
Network Nebraska Engineers are investigating an issue affecting redundant paths to several ESU03 schools via Windstream. We have contacted Windstream NOC for more information. No estimated time of resolution is available at this moment.
Posted Aug 12, 2025 - 14:47 CDT
This incident affected: Educational Service Units (ESU 3).