Allo rebooted their NID to restore the outage. This had the effect of expanding the outage and dropping a connection to Doane in Crete. All sites that went down due to this outage are responding again, please report any issues: 402-472-7656 Toll Free 888-638-6327 (1-888-NET-NEBR) or noc@nebraska.edu
Posted Nov 14, 2025 - 23:32 CST
Identified
Network Nebraska Engineering has identified an issue at the handoff point between Network Nebraska and Allo in Lincoln. We are currently awaiting further investigation and updates from Allo.
Posted Nov 14, 2025 - 21:48 CST
Investigating
We are currently investigating an outage related to services carried via Allo.
Posted Nov 14, 2025 - 21:28 CST
This incident affected: Private Non Profit Colleges / Universities (Union Adventist University), Educational Service Units (ESU 2, ESU 5, ESU 9, ESU 10, ESU 16), Special Schools (DHHS Kearney West High School, DHHS YRTC-Lincoln), and Public Libraries (Grand Island Public Library).