Multiple sites via Spectrum down

Incident Report for Network Nebraska

Resolved

All sites were back up by 9:40pm CT last night; Spectrum was hands off by 2:45am CT this morning. Please report any lingering issues to 402-472-7656 Toll Free 888-638-6327 (1-888-NET-NEBR) or noc@nebraska.edu.
Posted Mar 24, 2026 - 08:35 CDT

Update

Construction teams are on site and repair work is on-going.
Posted Mar 23, 2026 - 17:16 CDT

Identified

The carrier has confirmed that this is down due to a fiber cut, they anticipate that service will be restored by 8pm CT.
Posted Mar 23, 2026 - 15:27 CDT

Investigating

Multiple sites via Spectrum all dropped at 1:45pm CT, the carrier is investigating. No time to restoral is available.

ESU10-Amherst
ESU10-Ord
ESU10-Pleasanton
ESU10-SEM


Questions 402-472-7656 Toll Free 888-638-6327 (1-888-NET-NEBR) or noc@nebraska.edu
Posted Mar 23, 2026 - 14:43 CDT
This incident affected: Educational Service Units (ESU 10).