Multiple sites via Spectrum down

Incident Report for Network Nebraska

Resolved

All sites have remained stable, please report any issues to 888-638-6327 (1-888-NET-NEBR) or noc@nebraska.edu
Posted Mar 05, 2026 - 12:27 CST

Monitoring

All sites were back up as of 7:30pm CT, work is still on-going and there is a chance that sites could go back down until all work is complete.
Posted Mar 04, 2026 - 19:56 CST

Update

We are starting to see some sites restore, repairs are on-going.
Posted Mar 04, 2026 - 18:36 CST

Update

The carrier is half way done splicing.
Posted Mar 04, 2026 - 16:57 CST

Update

Excavation is on-going and a replacement cable is being prepared. Restoral time is still 5:30pm CT.
Posted Mar 04, 2026 - 15:05 CST

Identified

The carrier has confirmed that this is due to fiber damage and they have an estimated restoral time of 5:30pm CT.
Posted Mar 04, 2026 - 13:18 CST

Update

The carrier is continuing to work towards isolating the cause of the outage.
Posted Mar 04, 2026 - 11:44 CST

Investigating

Multiple sites via Spectrum all dropped at 9:52am CT, we are engaging the carrier now. No time to restoral is available.

ESU10-Amherst
ESU10-Ord
ESU10-Pleasanton
ESU10-SEM

Questions 402-472-7656 Toll Free 888-638-6327 (1-888-NET-NEBR) or noc@nebraska.edu
Posted Mar 04, 2026 - 10:30 CST
This incident affected: Educational Service Units (ESU 10).