Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 05, 2025 - 11:16 CDT
Scheduled
RFC 156414: NH Data Center will have reduced performance during maintenance. Direct impact: Outage to Peru State College (PSC), Southeast Community College (SCC), ESU02-Ceresco, ESU09-Harvard Schools, ESU09-Sutton Schools. Possible impact: Failover for Nebraska Wesleyan, ESU03-Elkhorn, NU Foundation - Lincoln Mall connections may cause issues. ITS's vendor will be moving an equipment rack during this time. Entered by - Loren Frerichs Questions 402-472-7656 Toll Free 888-638-6327 (1-888-NET-NEBR) or noc@nebraska.edu
Posted Oct 03, 2025 - 11:34 CDT
This scheduled maintenance affected: Educational Service Units (ESU 2, ESU 3, ESU 9), State Colleges (Peru State College), Community and Tribal Colleges (Southeast Community College Area), and Private Non Profit Colleges / Universities (Nebraska Wesleyan University).