Spectrum Network Outage

Incident Report for Network Nebraska

Resolved

This incident has been resolved.
Posted May 30, 2025 - 09:24 CDT

Monitoring

Sites have been restored, and Spectrum continues to investigate the cause of the outage.
Posted May 29, 2025 - 16:08 CDT

Investigating

We are currently investigating an issue impacting customers using Spectrum.
Posted May 29, 2025 - 15:38 CDT
This incident affected: Educational Service Units (ESU 2, ESU 7, ESU 10, ESU 11).